You need to log in to create posts and topics.

Missing Custom Textures

TL;DR - Missing custom textures. They show up in the material browser correctly, but once I apply them to a brush, the 'missing texture' texture appears.

First time poster here. I hope I've structured this post so that it's easy to understand.

To test out the process of creating textures for Portal 2, I decided to create custom dev textures using dev_measuregeneric01 and dev_measurewall01. I recolored them, exported the textures from photoshop as tga's, and converted them into vtf's using VTFEdit 1.3.3.

The textures show up in the texture browser within hammer, but once I apply any of them to a brush, I see the infamous purple and black texture.

I've put some screenshots here to hopefully illustrate what I'm experiencing: https://imgur.com/a/kFCb61k

My vmt's look like this:

Spoiler
Sorry, only logged-in users can see spoilers.

dev_measuregeneric01_white_a.vmt

Spoiler
Sorry, only logged-in users can see spoilers.

dev_measuregeneric01_white_b.vmt

Spoiler
Sorry, only logged-in users can see spoilers.

dev_measurewall01_noportal.vmt

Spoiler
Sorry, only logged-in users can see spoilers.

dev_measurewall01_white_a.vmt

Spoiler
Sorry, only logged-in users can see spoilers.

dev_measurewall01_white_b.vmt

Spoiler
Sorry, only logged-in users can see spoilers.
[/spoiler]

If anyone knows of something I could do to fix this, I'd be very grateful. Thanks for taking the time to read this.

Check if your texture path is correct !

About your VTF settings, i would recommand to disable mipmaps (vtf compression is < in quality than to resize the image in photoshop)

I apologize for the delayed response as I've been somewhat busy lately. First of all, I can't thank you enough for your suggestion of disabling mipmaps, I'm not sure how this fixed the problem but it has. However, this has introduced a new problem though small. Without generating mipmaps, the textures have visual artifacts when viewed from a distance.
Additionally the thumbnails for the textures in the texture browser look (for lack of a better term) glitchy. Here's a link to an imgur album which contains screenshots and more information: https://imgur.com/gallery/EUZBsTv

Either way, disabling mipmaps has proved to be an excellent temporary solution, but I would like to allow my textures to use mipmaps. Do you know of any ways that I could manipulate or add mipmaps to existing vtf textures or any other potential solutions to the original problem?

Use mipmaps only in this case: a texture with small details (as thin lines)
-> the only other tool i know which can create mipmaps is: Nvidia plugin for adobe photoshop
I gave up on using mipmaps, so i can't help you more with this i think

Btw, i'm against mipmaps because itt literally destroys the quality of your texture, especially seen from close, and your Portal2 test is not supposed to be huge enough to have noticeable artifacts
I've the glitch thing too, but who cares :lol:

Good luck for your project :thumbup:

Just wanted to quickly update you and anyone else reading this. I've had people on the discord server helping me and Taz used the Paint.net VTF plugin to save the textures. I've been using it since then and it has worked wonderfully.

I personally prefer to have the mipmaps since I don't care for the artifacts, but to each their own. Something is still wrong with VTFEdit, possibly a setting I've changed for the import process, but that's just speculation. All I know is I can create custom content again. Thanks for taking the time to help me out.

I had in head that VTFEDIT is the most updated version for VTF modifications, but if all works for u now then i'm happy :)