You need to log in to create posts and topics.

Hammer compile issue

So I added some lights in my map and now it compiles fine, but doesn't add any changes. It doesn't say I have a leak, and the error checker didn't find anything. here is my log:

log

Spoiler
Sorry, only logged-in users can see spoilers.

It looks like no problems compiling - everything says OK and done. The compiler should automatically create a bsp in Portal 2portal2maps folder and your log does say it did.

Code: Select all
Running command: copy "D:steamsteamappscommonPortal 2sdk_contentmapschamber1again.bsp" "D:steamsteamappscommonPortal 2portal2mapschamber1again.bsp"

Double check if this isn't the problem by copying over the bsp from 'D:steamsteamappscommonportal 2sdk_contentmapschamber1again.bsp'.

I had this problem once and realised that I was actually loading the wrong version of the map. So completely make sure you are loading the right map: chamber1again.

Edit: If you are running the map immediately after a map without lighting (fullbright) the map will still continue to be fullbright. You can turn this off by typing in the console mat_fullbright 0 or by restarting Portal.

?????????????????????????????TWP Releases | My Workshop
ChickenMobile wrote:
It looks like no problems compiling - everything says OK and done. The compiler should automatically create a bsp in Portal 2portal2maps folder and your log does say it did.

Code: Select all
Running command: copy "D:steamsteamappscommonPortal 2sdk_contentmapschamber1again.bsp" "D:steamsteamappscommonPortal 2portal2mapschamber1again.bsp"

Double check if this isn't the problem by copying over the bsp from 'D:steamsteamappscommonportal 2sdk_contentmapschamber1again.bsp'.

I had this problem once and realised that I was actually loading the wrong version of the map. So completely make sure you are loading the right map: chamber1again.

Edit: If you are running the map immediately after a map without lighting (fullbright) the map will still continue to be fullbright. You can turn this off by typing in the console mat_fullbright 0 or by restarting Portal.

Well the map wasn't in full bright because everything was dark, the light still doesn't work though, I even tried to activate it with a trigger but that didn't work
Edit: Music doesn't work, it's custom so I might of did it wrong, but it shows up in hammer and has a preview.
edit 2: fixed it, it was a tutorial I followed for custom music that made me add a extra compile option that breaks it.

Lights by default should be on unless the initially dark flag is checked. The default range of a light isn't actually that far, so I would suggest you move the light closer to a wall to so its' effects more clearly.

Your light entity should either be a 'light' or 'light_spot', light_environment and light_directional are reserved for skybox light only.

?????????????????????????????TWP Releases | My Workshop
ChickenMobile wrote:
Lights by default should be on unless the initially dark flag is checked. The default range of a light isn't actually that far, so I would suggest you move the light closer to a wall to so its' effects more clearly.

Your light entity should either be a 'light' or 'light_spot', light_environment and light_directional are reserved for skybox light only.

Thanks for the help, I'll keep that in mind