You need to log in to create posts and topics.

Custom skybox texture not working

I know this is a longshot since the activity on this site has dropped to near nil, but I need help.  I used Blender to create a custom skybox texture, followed all the directions on using VTFedit to create the six files needed, named them all correctly ("filename" + 2 character codes for which position), placed them in the material/skybox directory, changed the Skybox Texture Name ("filename" without directory position or angle characters) under Map Properties, but nothing works.  When I put in an old custom skybox texture, everything works fine.  (FYI, the new textures appear in Hammer as normal textures.)  I've used VTFedit to compare the settings on both old and new texture files and the only differences are image sizes (old 512 x 512, new 1024 x 1024) and versions.  I even tried redoing my new files changing to the older version.  Still didn't work.    I've included a zip file with my original images (png), my newly created VTF/VMT files, and the VTF/VMT files of the textures that actually work.  If somebody could help me figure out why the new textures won't work while the old ones will, I would be very grateful.  Thanks.

 

Edit: The Upload file didn't work, so here is a link to the files on Google Drive:  https://drive.google.com/file/d/1ySw7CTmvXbxxJpbOSxC3-6XgrNitLO7U/view?usp=sharing

 

Okay.  Solved this one with the help of my Steam friend Jofish.  The issue was in naming of the files.  Apparently, Source skyboxes don't like capitalization in file names.  Once I changed to all lowercase, the skybox worked flawlessly.  Figured I post this info just in case other people might find it useful.