You need to log in to create posts and topics.

Tanktrain stopping without trigger.

I've created a tanktrain that follows through 9 path_tracks. Track 9 has its Next Stop Target set for track 1 so the whole thing should be a continuous loop. The problem is that it stops on track 9 and won't continue. There are no triggers on any of the path_tracks that could cause this, and no objects to block the path. I've tried moving track 9's position, deleting it and remaking it, and even triggering a reverse on it, but nothing prevents the tanktrain from stopping at 9. Anyone have any clue why this is happening? Its very frustrating since this is literally the last thing required for my level to be complete. Thanks.

Check out my Science Fiction novels at

Fairly sure func_tanktrain is an obsolete / unpreferred entity as it has a fairly significant damage bug. Use a func_tracktrain instead.

I would suggest adding outputs to 'start' the entity again to see if stopping at the last track is some sort of default behavior.

EDIT: outputs can be manually fired in the console to save yourself the time of compiling.
A command might look something like this:

Code: Select all
ent_fire train_name StartForward

Tracks are only linked if a visible line is drawn between points. By default tracks auto-link when duplicated.

?????????????????????????????TWP Releases | My Workshop

Tried changing the func_tanktrain to a func_tracktrain. Kept everything else the same. Still had the stopping issue. I next tried deleted all of the path_tracks and entered them again from scratch. This worked. Not sure what caused the actual issue, but at least I got it working properly. Thanks for the input.

Check out my Science Fiction novels at