You need to log in to create posts and topics.

GLaDOS Lines Not Playing

Hello! I decided to pop into Portal 1 today to fool around, and was struck by GLaDOS not playing her voice lines. The subtitles were showing up, but no audio. I've already tried verifying the game, re-installing, rebuilding audio cache, etc., but it still comes up with the "not in disk/repository" console error. I've checked and the files are all in the GCF. I've been at it for an hour or so now, anyone have any ideas?

EDIT: I checked my activity feed in Steam, and there's something to do with a beta for users with a new Steam content delivery system. Is anyone else having the same problem as I, and if so is this new thing interfering with the game?

Image

The last time I played Portal 1 was three days ago, and I didn't have the problem then. When was the last time you played it before the problem started? Can you confirm it's a very recent thing, or is it something that might have been a problem for some time and you only just now replayed and discovered it?

I just made a fresh install with the beta and it's working fine! Maybe give the beta a go ;)

It fixed the voice problem, but this beta has one terrible side-effect: Sourcemods [including well established ones such as Portal Pro and Portal Prelude] do not work under this new system.

Image

Check what happens if you change the SteamAppId to 400 in the GameInfo.txt for the mods. Can't do that myself right now

Lpfreaky90 wrote:
Check what happens if you change the SteamAppId to 400 in the GameInfo.txt for the mods. Can't do that myself right now

I've already done that; so far all the mods are throwing up the following error:
"Can't find background image materials/console/startup_loading.vtf"
I'm going to see if that exists in the Portal folder; they've relocated it to Steamapps/common/Portal, and now it's in .pak format so . . . eugh.

EDIT: It appears that GCFscape can't open "portal_pak_dir.vpk", so that's a bummer.

Super-colliding-super-edit: So, I reverted to the non-beta after I read on the official bug-report place that the no-voices was a reported bug, and that Valve released an update today fixing it. As well, the beta removed the edge-glitch and the thing ruined mods with the .pak system. If they officially make Portal .pak [not beta], I will be mad for the rest of my life. Mods still aren't working, though.

Image